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Introduction 

Many existing laboratory clients of J Street LIMS use older versions of its predecessor, MSC-LIMS. There 

are two versions of MSC-LIMS still in use: versions 4 and 5. MSC-LIMS version 4 was originally released in 

2012 and stores all system data in a Microsoft Access .mdb database, compared to version 5 and J Street 

LIMS version 6 which use Microsoft SQL Server as the back-end database. For customers upgrading from 

MSC-LIMS version 4 to J Street LIMS version 6, it is necessary to undergo a database migration from 

Access to SQL Server to preserve laboratory data. 

 

J Street LIMS is supported by a team of Access & SQL Server experts who can provide a white glove 

database migration service for a flat $600 fee. This service includes an initial database migration for 

testing J Street LIMS version 6, and a second migration when you feel comfortable moving J Street LIMS 

version 6 into production. Some labs may prefer to handle the database migration with their own IT 

resources, in which case we provide these self-service migration instructions.   

 

IMPORTANT! Please read if choosing self-service database migration: 

For annual subscribers, if you choose to use these self-service instructions to migrate an MSC-LIMS 

version 4 database to SQL Server, please read and follow the instructions carefully. For clients with Full 

System Licenses to MSC-LIMS version 4, please contact our Support team before attempting a migration 

as we must individually review your database. Any customizations or alterations to the LIMS’ code or 

database structure may impact the migration process and require individual attention.  

 

Understand that migrating an MSC-LIMS Access database to SQL Server can likely involve downtime for your 

lab. This is because once the migration process begins, any data added to MSC-LIMS will not be 

transferred over in the migration. Typically, the migration process can be accomplished within an hour, 

but many factors can impact this timeframe and any issues or delays in the migration process can extend 

downtime. In order to minimize this downtime and maximize testing capabilities for self-service clients, J 

Street requires 2 database migrations: an initial test migration and a second migration to include production 

data added to MSC-LIMS during the testing phase. This ensures that you can continue to use MSC-LIMS v4 

in a production setting while updating your Excel templates for v6 compatibility.  It also lets you test the 

new software and updated Excel templates using your own data. Once you’re ready to begin using J 

Street LIMS v6 in production, follow these instructions a second time for a final migration of all your lab’s 

historical data and data that was added to MSC-LIMS v4 during the testing phase.  

 

 

Please also be aware that J Street Technology is an hourly software development firm. While we can 

respond to questions about the migration process over email, any troubleshooting that requires 

scheduling meetings, calls, or screenshares will be considered billable at J Street’s current hourly rate. 

Please consider your technical capabilities and budget before beginning this process as it is often more 

cost and time effective for our team to process both migrations for our flat fee. If you have questions 

about the above requirement or the migration process, please contact Support@JStreetLIMS.com. 
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SQL Server Migration Instructions 

What You Will Need: 

• MSC-LIMS version 4.1.0. If you have MSC-LIMS version 4.0.0 please contact us. Find your version 

number in the top left corner of the LIMS’ main menu.  

• An existing MSC-LIMS version 4 LimsData4.mdb database to migrate.  

• Download MSC-LIMS v4 to SQL Server migration files.zip from our Knowledge Base. 

• Install SQL Server Migration Assistant for Access (SSMA) 32 bit version from Microsoft. The 32 bit 

version will have “x86” at the end of the file name.  

• Install SQL Server Management Studio from Microsoft. Note this is automatically installed with 

most modern versions of SQL Server, including 2019.  

• Ensure you check the box for file names to show their file extensions in File Explorer.  

 

LIMS Data Access Upsize to SQL Server 2019 

 

Before attempting to migrate your database, ensure that you have a running instance of SQL Server 2014 

or newer, or that you’ve installed SQL Server Express 2019 according to our Installation Guide (available 

on our website’s Knowledge Base). 

 

1. Locate the original drive your MSC-LIMS v4 database file (LimsData4.mdb) is located in. The file 

pathway will be located in the lower lefthand corner on the LIMS’ Main Menu. Navigate to the 

database file in your File Explorer.  

2. Create a migration folder on the computer that you have SQL Server Express installed on. You will 

keep all your work in this folder. Make a copy of the current Access database to migrate to SQL 

Server, and then place the copy in that folder. Give the database copy the same name as your existing 

database, but add “Upsize” to the end of the file name. For example: LimsData4.mdb → 

LimsData4Upsize.mdb. 

IMPORTANT:  Please note that any new data added to the live database after the copy has been 

made will not be migrated to SQL Server. We recommend allocating an hour or two of downtime 

for this process, or manually adding samples to the new LIMS database after the migration is 

complete. 

3. Visit the J Street LIMS Knowledge Base and download the MSC-LIMS v4 to SQL Server migration 

files.zip and extract the contents into your Downloads folder. 

4. If you do use the MSC-LIMS Messaging component, find the location of LimsMsgs4.mdb in the lower 

left corner of the LIMS Messaging main screen. Copy LimsMsgs4.mdb to LimsMsgs4Upsize.mdb in the 

same folder as LimsData4Upsize.mdb, then repeat step #6 with file LimsMsgs4Upsize.mdb to remove 

its user-level security. 

5. If you do not use the MSC-LIMS Messaging component, copy the supplied LimsMsgs4Upsize.mdb 

extracted in step #3 to the same migration folder you’re saving your work in. 

http://www.jstreetlims.com/knowledge-base
https://www.microsoft.com/en-us/download/details.aspx?id=54255
https://learn.microsoft.com/en-us/sql/ssms/download-sql-server-management-studio-ssms?view=sql-server-ver16
http://www.jstreetlims.com/knowledge-base


 

Removing User Level Security  

IMPORTANT! Please Read: MSC-LIMS version 4 uses Access 2010 user-level security, meaning user 

credentials are stored in the Access database. MSC-LIMS v5 and J Street LIMS v6 use a combination of 

Windows Authorization (your Windows login account) and SQL Server authentication in place of this. 

Therefore, we must remove user-level security from the application. The process to do this varies based 

on what version of Access you are using (Access 2010 or Access 365 versions). Please follow one of the 

two sets of instructions below based on which version of Access you’re using. For Access 2010, follow 

Steps #6 & #7. For Access 365, follow Step #8. 

 

Instructions for Access 2010: 

6. Create a new shortcut to start a full copy of Microsoft Access with workgroup security file 

LimsUser4Upsize.mdw extracted in step #3. Here is an example shortcut Target property: 

"C:\Program Files\Microsoft Office\Office14\MSACCESS.EXE" /wrkgrp "C:\path\to\your\migration\folder\LimsUser4upsize.mdw" 

7. Remove LimsData4Upsize.mdb user-level security in Access 2010. 

A.  Start Access 2010 with LimsUser4Upsize.mdw using the shortcut created in step #6.  

B.  Open LimsData4Upsize.mdb.  

C.  Click File > Users and Permissions > User and Group Permissions (see below screenshot). 

 

 

 

Select the Admin User/Group Name. In the Object Type field, select Table. In the Permissions area 

below, check each permission box to give the Admin user full permissions to all tables in the 

database:  



 

  

 

D.  Next, in the Object Type field, select Database. You may be prompted to change permissions 

now, Click Yes. 

 

Next, give the Admin user Open/Run, Open Exclusive, and Administrative permissions, then click 

OK 

 

 



 

E. Exit Microsoft Access. In your File Explorer, double click LimsData4Upsize.mdb (not the 

shortcut) to ensure Access can open the file without LimsUser4mdw (indicating the file is no 

longer secured). 

Instructions for Access 365: 

8.  If you do not have a full version of Access 2010 you can remove User Level Security with Access 365, 

the version installed with Office 365. While J Street LIMS will work with any version of Access from 2010 

onward, this step should be identical for most modern versions. The easiest way to do this is to convert 

the .mdb file to .accdb. You will still need to use the shortcut that incorporates the LimsUser4Upsize.mdw 

file to open the .mdb file. For example, when creating a shortcut in your Upsize folder copy and paste the 

following with your folder structure in the ‘Type the location of the item’ box and click Next. 

 
"C:\Program Files\Microsoft Office\root\Office16\MSACCESS.EXE" /wrkgrp "C:\path\to\upsizefolder\LimsUser4upsize.mdw" "C:\ 
path\to\upsizefolder \LimsData4Upsize.mdb" 

 
 

Then change the shortcut name to something other than the default (see below) then click Finish. 

 

 
 



 

Open the LimsData4Upsize.mdb with the new shortcut.  Click File on the Menu Bar. Then click on Save As 

on the left side of the screen. Then click on Access Database (*.accdb). Then click Save As in the middle 

of the screen.  
 

 
 

Upsizing the Database 

9.   Open the Upsize database (you may have to click enable to edit the database). From the Database 

Tools menu tab, click the Compact and Repair Database option. 

 

  
 

Next, press Ctrl + G to open the Code window.  

 

10.   In the Code window, open the File menu and choose “Import File…”. Then navigate to the extraction 

folder from step #3. Right click on the Upsizing Functions.bas file and select Properties, then check the 

Unblock option (Otherwise you will not be able to import the code). Click OK to close the Properties 

window. 

 

 



 

 

 

Ensure the Upsizing Functions.bas file is selected, then click Open. The file will open as a module in the 

Project Explorer window. 

 

 
 

You may have to expand the Modules in the Project window. Right click on Upsizing Functions and click 

View Code to open the code in the code window. 

 

 

 

Update the References 

11.   From the Menu, select Tools > References, and checkmark the references to match the screenshots 

below for your version of Access, then click OK: 

  



 

 

Below is a screenshot of the References dialogue box in Access 2010. 

 
 
Below is a screenshot of the References dialogue box in Access 365. 

 

Check for Errors 

12.   Next click Debug > Compile limsdata to see if there are any errors in the code. IMPORTANT: You 

will not receive a confirmation message from Access if there are no compile errors—please proceed to 

Step #14 if this is the case. If you receive any error messages, proceed to Step # 13. 

 

 



 

 

13.   If you receive any error messages (like the one below), double check that you’ve selected the correct 

checkboxes in the Tools→References dialogue box in Step #11. If you made changes to the checkboxes in 

the References dialogue box, then click Debug > Compile to see if the errors have been resolved. If you 

continue to get errors, please contact J Street LIMS Support Team at Support@JStreetLIMS.com.  

 

 

 
 

14.   Once there are no errors, type or copy/paste PrepareDatabaseForUpsizing into the Immediate 

window (View→Immediate Window) and press “Enter” on your keyboard to update the Access database 

to prepare for the migration to SQL Server.  

 

 
 

After the process completes, you will see [ok] appear in the Immediate Window, per below.  

 

 
At this point, close Microsoft Access and save your changes.  
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Open SSMA (SQL Server Migration Assistant for Access) 

15.   Open SQL Server Migration Assistant for Access. Click Next. 

 
 

16.   Enter a name for the migration project and save it to the migration folder you created in Step #2. 

Select the SQL Server version you have installed and want to migrate your data to. Click Next. 

 

  

                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  

 
17.   Click the Add Databases button then browse to the folder where you saved LimsData4Upsize.mdb in 

Step #2 (see below).  

 



 

 
 

 

                                                                                                                                                                                                                                                                                                                                                                    

 
 

18.   If you removed User-Level Security by saving the Upsize file to .accdb (as described in Step 8), then 

select LimsData4Upsize.accdb, otherwise select LimsData4Upsize.mdb, then click Open. 

 

 

19.   All table objects must be migrated to SQL Server. Check the tables folder to automatically select all 

table objects beneath, then click Next. 

  



 

 
 

20.   In the Server name field, select the SQL Server to migrate to using your server name. In the Database 

field, enter a name for your database. The database name should include the word LIMS along with your 

company abbreviation. If this is a test migration, append the word Sandbox at the end of the database 

name. For example: the fictitious company Wind River Labs would use LimsWRL or LimsWRLSandbox. 

 

 
 

21.   Click Next. Then click Yes to create the database when prompted.  

 

 



 

 
 

22.   We are not linking back to the Access database from LIMS. Make sure the “Link Tables” checkbox  

is not selected, then click Next. 

 

 

 
 

 

23.   SQL Server Migration Assistant will process all the selected objects. Depending on the size of the 

Access database, it may take 10-20 minutes to migrate the objects and data to SQL Server. 

 



 

 
 

Once complete SSMA will show all the objects that were migrated. Click OK. 

 

 
 

Check for any Errors in the Migration Status window. In the unlikely event errors appear, take screenshots, 

download the reports, and email J Street LIMS Support Support@JStreetLIMS.com. Make sure to include 

the screenshots and reports in your email. Click Close. 
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24.   You may now Exit SQL Server Migration Assistant. 

Open SQL Server Management Studio (SSMS) 

25.   Open SQL Server Management Studio (SSMS). Select the server name you will be hosting the LIMS 

database on. Click Connect. 



 

 
 

Verify the database name you set in Step #20 (in this example, JStreetLims) appears under the Databases 

folder and look at the larger tables like Samples, Analysis, and Sample Analysis for data issues. 

 

 
 

26.   Next run JStreet-LIMS 500 Setup.sql SQL script. This script file will update the SQL Server indexes, 

objects, and stored procedures. From the SQL Server menu Click Open > File.  

 



 

 
 

The Open File dialogue box will open. Browse to the folder with the .sql script. The file is in the extracted 

zip folder under Downloads as created in Step #3. 

 

 
 

Select the SQL script and click Open. The script will open in a query tab.  

 

 

27.   Change the Use Clause to the name of the database as set in Step #20. Click the Execute button 

that is just above the query tab. Again, check for errors in the Messages tab at the bottom of SSMS. If 



 

there are any errors, copy all of the text from the messages window and email it to 

Support@JStreetLIMS.com. If you see no errors, close SSMS by clicking File → Exit. Click “Yes” to save 

changes to the file.  

 

 
 

Install the J Street LIMS Application  

 

28.   You have now successfully migrated data from your MSC-LIMS version 4 Access database to a new 

SQL Server database. You may now proceed with installing the next version of LIMS according to your 

upgrade pathway and connect it with the new SQL Server database you just created. 
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Contact Us 

J Street Technology, Inc. 

16625 Redmond Way, Ste. M, PMB 463 

Redmond, WA, 98052 

(425) 679-6206   (ext. 2 for Support requests) 

 

Support@JStreetLIMS.com 

Sales@JStreetLIMS.com 
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